Дано два натуральных числа а и в. напишите программу, которая находит цифру, на которую заканчивается число а в степени b (ab).

VlabaR265 VlabaR265    3   28.10.2019 13:05    6

Ответы
Никто25555 Никто25555  05.08.2020 09:21
C++

#include <cmath>

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL,"RUS");

  unsigned long a,b;

   cout<<"Введите число а"<<endl;

   cin>>a;

   cout<<"Введите число b"<<endl;

   cin>>b;

   cout<<((unsigned long)pow(a,b))%10;

   system("pause");

   return 0;

}

C#

using System;

class Power {

 static int Main() {

   ulong a, b;

   Console.WriteLine("Введите число а");

   a=Convert.ToUInt64(Console.ReadLine());

   Console.WriteLine("Введите число b");

   b=Convert.ToUInt64(Console.ReadLine());

   Console.WriteLine(Math.Pow(a,b)%10);

   Console.ReadKey();

   return 0;

 }

}

Pascal

program Power;

uses crt;

var

a,b,c:Int64;

i:byte;

begin

 writeln ('Введите число a');

 readln(a);

 writeln ('Введите число b');

 readln(b);

 

 c:=1;

 for i:=1 to b do

 c:=c*a;

 

 writeln (c mod 10);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика