Дано четырехзначное число. написать программу, которая находит число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа.

HAHAEZ2010 HAHAEZ2010    3   19.03.2019 13:50    11

Ответы
LitunIlya LitunIlya  26.05.2020 03:30

program a1;
var
a,b,c,r:byte; l,k:word;
begin
read(l);
a:=l mod 10;
b:=l div 10 mod 10;
c:= l div 100 mod 10;
r:= l div 1000 mod 10;
k:=c*1000+r*100+a*10+b;
write(k); end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика