Данная программа производит реверс цифр целого числа, введенного с клавиатуры пользователем.
Задача заключается в том, чтобы, например, число 12345 переписать как 54321.
Текст программы:

#include "stdafx.h"
#include
#include

int _tmain(int argc, _TCHAR* argv[])
{
long int x, r;

printf("\n Enter an integer: ");
scanf_s("%ld", &x);

printf("\n Reverse-digit number %ld:\n\n\t", x);

do {
r = x % 10;
printf(" %ld", r);
x = x / 10;
} while ( x != 0);

printf("\n\n Press any key: ");
_getch();

return 0;
}

В программе применена арифметическая операция деления по модулю, которая имеет символ процента, т. е. «%». Любой остаток, получающийся в результате деления целых чисел, будет отброшен. В шкале старшинства оператор деления по модулю имеет приоритет, равный приоритету операторов умножения и деления. Переменные, используемые в программе, объявлены как длинные числа, поэтому применен тип long int .
Задание для самостоятельной работы:
1. Наберите и запустите приведенный выше пример в среде Visual Studio Express.
2. Модифицируйте программу таким образом, чтобы она выполняла подсчет числа итераций заданного цикла.
3. Определите максимальное число вида 123...987..., для которого еще можно применить тип long int.

лимпоьип лимпоьип    2   01.04.2020 14:23    1

Другие вопросы по теме Информатика