tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
дана строка символов t. напишите
"дана строка символов t. напишите программу, которая добавит перед и после каждой гласной буквой строки – букву ‘p’. например, ‘corectitudine’ станет ‘’. "написать на c++
Сникерс11
1 12.09.2019 08:50
5
Ответы
ASabina1111111
07.10.2020 09:17
#include <iostream>
#include <set>
using namespace std;
int main()
{
string t, s="";
cout << "t = ", cin >> t, cout << endl;
set<char> a = {'a','e','i','o','u','y'};
for(int i=0; i<t.length(); i++)
if(a.find(t[i]) == a.end()) s = s+t[i];
else s = s+'p'+t[i]+'p';
cout << s << endl;
return 0;
}
Пример:
t = corectitudine
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
жуля7
22.07.2019 19:10
Составить программу вычисляющую сумму квадратов первых n натуральных чисел. количество чисел n задаётся во время работы программы. для разработки использовать приложение visual...
vinchez1
05.06.2019 15:50
Напишите процедуру,которая переставляет три переданные ей числа в порядке возрастания. пример: 10 15 5 5 10 15...
яестьумник
05.06.2019 15:50
А(20) найти сумму элементов, стоящих на четных местах. составить таблицу и программу...
александр383
21.05.2019 06:10
Подскажите заранее где находится в paint 1) строка меню 2) строка состояния 3) строка заголовка(это не само названия приложения) умоляю...
белка263
04.04.2020 21:46
Дан рекурсивный алгоритм: procedure F(n: integer); begin writeln(n); if n 5 then begin F(n+3); F(n*3) end end; Выделите цветом те числа, которые будут выведены при вызове F(1)....
rahbfwBbdqbqdI
04.04.2020 21:47
Чим відрізняється інформаційна безпека від комп’ютерної безпеки? (висловіть власні думки) За матеріалами Інтернету підготуйте 1-2 реальні історії про порушення інформаційної...
Магомед05111
16.06.2019 20:30
Сослать программу на паскале.поиск чисел в массиве. program example; {программа заполняет массив rand случайными числами в диапазоне от 0 до 50, вводит число х, и вычисляет,...
Aixerel
13.05.2020 10:16
Буфет реализовал N пирожков по цене 660 руб. и М пирожных по цене 850 руб. За пирожки или пирожные выручка быльшей? Ввод: сколько пирожков реализовано? 25 сколько пирожных реализовано?...
vtrnnst
13.05.2020 10:16
17. Вычислите функции y=x+10, y=-x+60 при зна- br / чениях х -6; 1; ...; 57 и постройте сравнительную диаграм- br / му значений функций у1 и у2...
uIia454
13.05.2020 10:16
Паскаль Написать программу, которая проверяет, образуют ли элементы массива Х[1..10], введенного с клавиатуры неубывающую последовательность. Только без использования...
Популярные вопросы
Вшколе были организованы походы, осенью-пешие, зимой-на лыжах. из 30 человек...
1
Перечислить элементы композиции трагедии...
3
Даны два целых числа а и b. проверьте истинность высказывания справедливы...
3
Расстояние по реке между пунктами а и в туда и обратно катер проходит за...
3
Составь и запиши предложения с данными словами везти печь сколько вариантов...
3
Напишите интересные факты о британии! , заранее на...
1
Нужно по ,на тему мой кумир,любой кумир,но желательно актер,хотябы 15 большушее!...
2
4+5=9 кол-во платьев и халатов 36: 9=4м пошло на пошив одной еденицы 4*4=16м...
3
Мясо теряет прив арке 35% своего веса. сколько свежего мяса надо взять, чтобы...
2
Как будет“я могу делать фотографии” на...
2
#include <set>
using namespace std;
int main()
{
string t, s="";
cout << "t = ", cin >> t, cout << endl;
set<char> a = {'a','e','i','o','u','y'};
for(int i=0; i<t.length(); i++)
if(a.find(t[i]) == a.end()) s = s+t[i];
else s = s+'p'+t[i]+'p';
cout << s << endl;
return 0;
}
Пример:
t = corectitudine