Дана последовательность 1, 6, 11, 16, … . Составьте программу для
определения числа слагаемых, сумма которых не превышает 423.

Lukasheva1928 Lukasheva1928    1   23.04.2020 08:19    1

Ответы
743Slivka 743Slivka  24.08.2020 01:40

[python]

x, count = 1, 1

while(True):

   x += 5

   if x < 423:

       count += 1

   else: break

print(count)

[pascal]

var x, count: integer;

begin

   x := 1;

   count := 1;

   while(True) do

   begin

       x := x + 5;

       if x < 423 then count := count + 1

       else break;

   end;

   writeln(count);

end.

Почему count начинается с 1. Т.к. в последовательности есть число 1 (начальное значение x), то оно тоже является слагаемым и поэтому счетчик слагаемых начинаем с 1

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика