Дана матрица с(n×n) и вектор а(a1,a2,).написать программу вычисления вектора b=c*a. в паскале .

111122223 111122223    2   01.10.2019 21:50    5

Ответы
romatrapkin9091 romatrapkin9091  09.10.2020 10:26

const n=5;

var c:array[1..n,1..n] of integer;

a, b: array[1..n] of integer;

i, j, s: integer;

begin

Randomize;

writeln('Исходный массив С:');

for i:=1 to n do

begin

for j:=1 to n do

 begin

  c[i,j]:=random(10);

  write(c[i,j]:4);

 end;

 writeln;

end;

writeln('Исходный массив a:');

for i:=1 to n do

 begin

  a[i]:=random(10);

  write(a[i]:4);

 end;

 writeln;

for i:=1 to n do

begin

s:=0;

for j:=1 to n do s:=s+c[i,j]*a[j];

b[i]:=s;

end;

writeln('b=C*a');

for i:=1 to n do write(b[i]:4);

 writeln;

end.

Пример:

Исходный массив С:

  3   9   2   3   5

  3   9   5   6   9

  9   2   1   7   8

  5   2   0   3   2

  8   6   6   1   3

Исходный массив a:

  8   6   9   1   7

b=C*a

134 192 156  69 176

ПОКАЗАТЬ ОТВЕТЫ
nastyakarmazina1 nastyakarmazina1  09.10.2020 10:26
PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018Внимание! Если программа не работает, обновите версию!

uses NumLibABC;


begin

 var n := ReadInteger('n=');

 Println('Введите построчно элементы матрицы С');

 var C := new Matrix(n, n, ReadArrReal(n * n));

 Println('Введите элементы вектора a');

 var a := new Vector(ReadArrReal(n));

 var b := C * a;

 Println('Полученный вектор b');

 b.Println

end.


Дана матрица с(n×n) и вектор а(a1,a2,).написать программу вычисления вектора b=c*a. в паскале .
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика