Дан одномерный массив Y, состоящий из 15 элементов. Подсчитать сумму и произведение элементов массива, меньших 30. Написать программу решения задачи на языке программирования здесь

LanaStreet LanaStreet    1   24.11.2020 18:45    8

Ответы
ssyyppeerrmmaax ssyyppeerrmmaax  24.12.2020 18:46

var a: array [1..15] of integer;

i, n, s, p: integer;

begin

s:=0;

p:=1;

Read(n);

For i:= 1 to n do

Read(a[i]);

For i:=1 to n do

if a[n]<30 then begin

s:=s+a[i];

p:=p*a[i];

end;

Write(s, ' ', p);

end.

ПОКАЗАТЬ ОТВЕТЫ
vomid5421 vomid5421  24.12.2020 18:46

s,pr = 0,1

Y = []

for i in range(30):

   Y.append(int(input()))

for i in range(30):

   if Y[i] < 30:

       s += Y[i]

       pr *= Y[i]

print(s,pr)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика