Дан одномерный массив. Написать программу, которая находит значение максимального элемента и заменяет его на значение произведения элементов
(остальных) массива (второй массив не использовать). Программа выводит
исходные данные и измененный массив.

rfrfrfrfe rfrfrfrfe    1   28.05.2021 13:05    2

Ответы
rambobamborap08ffj rambobamborap08ffj  27.06.2021 13:05

Объяснение:

Python

from random import randint

n=int(input('Введите размер матрицы  :'))

a=[randint(1,20) for j in range(n)]

print(a)

m=max(a)

ind = a.index(m)

print('Максимальный элемент a[',ind,']=', m)

p=1

for i in range(n):

  if i!=ind:

     p*=a[i]

a[ind]=p

print(a)


Дан одномерный массив. Написать программу, которая находит значение максимального элемента и заменяе
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика