Дан одномерный массив d ,размерностью 20. элементы массива - это целые числа из промежутка [0; 750]. напишите программу в паскале ,вычисляющую количество элементов массива больших 500, которые кратны числу 15.

Капуста11111 Капуста11111    1   08.06.2019 21:20    5

Ответы
Lizikjung Lizikjung  07.07.2020 21:59
const
  n=20;
var
  i,k,e:integer;
  a:array[1..n] of integer;
begin
  Randomize;
  k:=0;
  for i:=1 to n do begin
    e:=random(750);
    a[i]:=e;
    if (e>500) and (e mod 15 =0) then
      k:=k+1;
    write(e:4)
    end;
  writeln; 
  writeln('Найдено чисел: ',k);
end.

Тестовый пример:

 262 743 705 288 545 694 437 280 317 434  53 344 302 293 246 200 608 194 523 478
Найдено чисел: 1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика