Дан одномерный массив целых чисел, состоящий из 20 ячеек, заполненный случайными числами из промежутка [-100,90]. увеличить каждый элемент массива на 100. напишите программу со всеми объяснениями

Egolaspro Egolaspro    2   13.07.2019 10:40    6

Ответы
Rukishka05 Rukishka05  18.09.2020 23:54
Написал две программки на случай, если там все таки массив  определен:
1)
var
a:array[1..20]of integer;
i,n,c:integer;
begin
 for i:=1 to 20 do
  begin
   read(a[i]);
   a[i]:=a[i]+100;
  end;
  for i:=1 to 20 do
  write(a[i],' ');
  end.

2)
var
a:array[1..20]of integer;
i,n,c:integer;
begin
  for i:=1 to 20 do
  begin
   a[i]:=random(191)-100;
   write(a[i],' ');
  end;
  writeln;
  for i:=1 to 20 do
  write(a[i]+100,' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика