Дан одномерный массив целых чисел размерностью 20. определите количество положительных групп в этом массиве. (группа это последовательность состоящая из 2-х и более положительных чисел находящихся рядом.)

nargizcavid nargizcavid    2   25.05.2019 19:40    5

Ответы
nastasttv00 nastasttv00  22.06.2020 02:14
Const  N=20;
Var  m:array[1..N]of real;
  i, group:byte;
  fl: boolean;
Begin
     for i := 1 to 20 do
     begin
         m[i] := random(20) - 10;
         writeln('[', i, '] => ', m[i]);
     end;

  group:=0;
 fl:=false;
  for i:=1 to N-1 do
    If (m[i]>0) and (m[i+1]>0) Then
fl:=true   
else
    if fl and (m[i+1]<=0) then
 begin
 inc(group);
 fl:=false
 end;
  if (fl) then inc(group);
  writeln(group);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика