Дан одномерный массив целых чисел.написать программу подсчёта количества положительных и отрицательных чисел массива.

svetlans2 svetlans2    3   20.06.2019 18:10    2

Ответы
isadulla isadulla  02.10.2020 06:25
Var ar : array [1..100] of integer;
i, pluscount,minuscount,zerocount : integer;
begin
readln(n); -считываем число элементов массива(если оно дано, я не знаю)
for i := 1 to n do
begin
read(ar[i]);  - считываем элемент массива, заносим его в массив
if (ar[i] > 0) then pluscount := pluscount+1; -если >0 -> увел. счетчик пол.чисел
if (ar[i] < 0) then minuscount := minuscount+1; -если <0 -> увел. счетчик отр.чисел
if (ar[i] = 0) then zerocount := zerocount+1; -если =0 -> увел. счетчик нулей
end;
writeln('В массиве ',pluscount,' положительных чисел, ',minuscount,' отрицательных чисел, ',zerocount,' нулей.');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика