Дан одномерный массив a размерностью n(< =0). значение массива ввести с клавиатуры, заполнить массив с генератора случайных чисел. найти среднее арифметическое и количество всех положительных элементов массива)) составить программу в паскале, буду : )

Gryzdik Gryzdik    1   05.06.2019 09:30    1

Ответы
HNLLZ HNLLZ  01.10.2020 19:44
Program Program1;
var i, n: integer;
var result1, result2, sum: real;
var array1: array [0..1000] of real;
begin
     randomize;
     result1 := 0;
     sum := 0;
     write('Введите значение N (не менее 0 и не более 255): ');
     readln(n);
     for i := 1 to n do
         begin
          array1[i] := random(1000) - random(1000);
         end;
         begin
          writeln('Массив размером - ', n, ' элементов(а):');
          for i := 1 to n do write(array1[i], ' ');
          writeln;
         end;
     for i := 1 to n do
         begin
          if array1[i] > 0 then result1 := result1 +1;
         end;
     for i:=1 to n do sum := sum + array1[i];
     result2 := sum / n;
     writeln('Количество положительных элементов массива = ', result1);
     writeln('Среднее арифметическое = ', result2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика