Дан одномерный целочисленный массив A[15]. Элементы массива вводятся с
клавиатуры. Написать программу, которая будет находить сумму положительных
элементов массива, стоящих на нечетных местах.

инна1382 инна1382    3   10.04.2020 14:58    4

Ответы
countrestrikegl countrestrikegl  30.07.2020 13:05

var A: array [1..15] of integer;

var i,s: integer;

begin

s:=0;

for i:=1 to 15 do

 begin  

 read(A[i]);

 if (A[i]>0) and (i mod 2 <>0) then s:=s+A[i];

 end;

writeln('Сумма положительных',

' элементов массива, стоящих на нечетных местах: ',s);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика