tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив вещественных
Дан массив вещественных чисел x(x1? ).найти произведение положительных элементов массива и подсчитать их число.
iruna4
1 14.06.2019 19:20
2
Ответы
Черноболь666
12.07.2020 08:54
Const n=5;
var
x:array[1..n]of real;
i,k:integer;
p:real;
begin
p:=1;
for i:=1 to n do
begin
readln(x[i]);
if x[i]>0 then
begin
p:=p*x[i];
k:=k+1;
end;
end;
writeln('p=',p);
writeln('k=',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
qmerry128
03.04.2019 13:28
Решить с паскаля +объяснить почему много ⦁ вычислить сумму последовательности , где n вводится пользователем, и вывести ее на экран. ⦁ вывести на экран количество...
Ekaterinakozlik
03.04.2019 13:25
Пиксел имеет rgb цвет 24 битный, какой код имеют : а)белый пиксел , б)чёрный пиксел, в)синий пиксел, г)желтый пиксел....
тикон3
13.03.2021 02:02
Реши задачу. (ответ округли до целых). Книга содержит 135 страниц. На каждой странице 38 строк. В каждой строке 57 символов (включая пробелы). Найти информационный...
Vad1mm
13.03.2021 02:06
будь ласка до іть 1) приклад2)що має вийти...
burkhanovshukh
13.03.2021 02:33
Между населёнными пунктами A, B, C, D, E, F построены дороги, протяжённость которых (в километрах) приведена в таблице.Определите длину кратчайшего пути между пунктами...
altynbekova2003
15.08.2019 07:50
Дима недавно сменил провайдера. он не помнит какой конкретно у него тариф, но знает, что файл размером 450 кб он передает за 38 секунд. сколько полных мб данных...
vgoidin
15.08.2019 07:50
Написать программу, которая выводит массив в обратном порядке. написать три функции (заполнение массива, вывод данных, вывода в обратном порядке). сделайте по с...
SuperAlinina
15.08.2019 07:40
Даны координаты двух противоположных вершин прямоугольника: (x1,,y2).стороны прямоугольника параллельны осям координат.найти периметр и площадь прямоугольника....
klara90
15.08.2019 07:40
Пункт главного меню с которого пользователь получает доступ к программам установленным на его компьютере...
Arina200444
15.08.2019 07:40
Вид списка 14 букв вторая а пятая р...
Популярные вопросы
.(Найти сторону равнобедренного треугольника, если две другие...
2
.(На полке стоят n книг. сколькими можно взять m из них так,...
3
Рассчитать, на сколько градусов следует понизить температуру...
3
На примере пропионового альдегида (пропаналя) и диметилкетона...
2
Напишите уравнение реакции, с которой ненасыщенный диолеолиноленглицерид...
1
Внаходиться воздух при температуре 500к. давление по манометру...
2
.(Удвух товарищей было 675 рублей. если один из них отдаст другому...
2
Площадь одной грани 16см2 вычисли площадь других граней и объём...
1
Вычислите, каким сопротивлением обладает нихромовый проводник...
1
Первый поезд преодолевает расстояние между двумя за 2.5 ч, а...
2
var
x:array[1..n]of real;
i,k:integer;
p:real;
begin
p:=1;
for i:=1 to n do
begin
readln(x[i]);
if x[i]>0 then
begin
p:=p*x[i];
k:=k+1;
end;
end;
writeln('p=',p);
writeln('k=',k);
end.