tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив.увеличить
Дан массив.увеличить каждый положительный элемент вдвое и подсчитать их сумму
SuperDusia
3 05.07.2019 00:50
1
Ответы
Оарп
28.07.2020 15:19
Const n=10;
var a:array[1..n] of integer;
s,i:integer;
begin
writeln('vvedite massiv=');
for i := 1 to n do
readln(a[i]);
s:=0;
p:=1;
for i := 1 to n do
if a[i]>0 then begin
s:=s+a[i];
a[i]:=a[i]*2;
end;
writeln('s=',s);
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
TheEasyCloud
19.05.2020 23:15
Ребята короче это клава от моего старого планшета и чехол я хз от какой фирмы чехол но самое главное мне короче нужено название этого планшета. На клаве нечего не написано ни...
vitlikkushnirp08qv4
24.02.2021 13:08
age = 10 if age == 10 :print( privet )... При выполнение этой программы будет ли выведено слово привет на экран?...
АняПоторалова
24.02.2021 13:08
Дан одномерный массив, состоящий из N вещественных элементов. Ввести массив с клавиатуры. Найти и вывести минимальный по модулю элемент. Вывести массив на экран в обратном порядке....
svelt04
24.02.2021 13:10
Алг нач цел s, k s := 0 нц для k от 4 до 8 s := s + 7 кц вывод s кон ответ:...
Котанская
25.07.2019 15:30
Решить, ) var a,b,t,m,r : integer; function f(x: integer): integer; begin f : = 9 * (x + 19) * (x - 19) + 1; end; begin a : = -20; b : = 20; m : = a; r : = f(a); for t : = a...
alinadudocka
25.07.2019 15:30
Данные точек а(6; 16) в(4; 4) с(9; 12) d(3; 12)е(8: 4)f(6; 16) соединив иха алфавитном порядке получим изображение а) елки)б) стрелки)в)звезды) пирамиды...
Alys1
25.07.2019 15:30
Почему компьютер можно называть системой2. дай характеристику мобильного телефона3. чем характеристика мобильного телефона может отличаться от характеристики компьютера...
olgas2000
10.08.2019 02:50
Какое минимальное основание может иметь система счисления, если в ней записаны все следующие числа 285, 132, 66555, 9365?...
zac00
10.08.2019 02:50
Укажите, какие числа записаны с ошибками: 581(7), 3021(4), 12598(9), а81f116, 13469(8). обоснуйте ответ....
autosteklo777
10.08.2019 02:50
Сколько различных решений имеет уравнение (k v l)v (l^m^n)=0...
Популярные вопросы
6. Bo Сколько разувеличится периметр квадрата, если его площадьувеличилась...
2
Природные ресурсы – это основа жизни любого человеческого общества. К ним...
3
ответьте на вопросы: В каких случаях оператор, называется линейным?Каким равенством...
2
Сұрақтарға жауап беріп, диалог кұрыңдар. 1. Акын неге өзін «таулыкпын» деп...
1
Что символизирует утонченный романтический образ «соловьиного сада» в поэме...
2
2. Какие были взаимоотношения между партиями? ну очень...
1
Почему город остался горькой легендой в веках отрарская поэма...
2
естествознание соч 5 класс 1 четверть ЭТО ПО ЕСТЕСТВОЗНАНИЕ,я просто нечайно...
1
Какому из интервалов действительных чисел принадлежит число √3...
2
Шалкиіз жырау. «Би Темірге бірінші толғау». Терминге сәйкес анықтаманы көрсет.Идея...
2
var a:array[1..n] of integer;
s,i:integer;
begin
writeln('vvedite massiv=');
for i := 1 to n do
readln(a[i]);
s:=0;
p:=1;
for i := 1 to n do
if a[i]>0 then begin
s:=s+a[i];
a[i]:=a[i]*2;
end;
writeln('s=',s);
readln;
end.