Дан массив, состоящий из целых чисел. известно, что числа по неубыванию (то есть каждый следующий элемент не меньше предыдущего). напишите программу, которая определит количество различных чисел в этом массиве. входные данные сначала задано число n — количество элементов в массиве (1n100). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести единственное число - количество различных чисел в массиве. примеры входные данные 5 1 1 1 1 1 выходные данные 1

mitya0558dima1096 mitya0558dima1096    1   24.06.2019 09:00    17

Ответы
TuttiFrutti56 TuttiFrutti56  02.10.2020 10:09
Program X;
var
mas: array[1..1000000] of longint;
N,i,count:longint;
begin
count:=1;
readln(N);
for i:=1 to N do
 read(mas[i]);
if N>1 then
 begin
  for i:=2 to N do
   if mas[i]<>mas[i-1] then inc(count);
  writeln(count)
 end
         else
 writeln(1)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика