tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив состоящий из
Дан массив состоящий из 9 элементов со значениями -3 до 3. подсчитать кол-во отрицательных чисел
irina956
2 22.07.2019 03:20
2
Ответы
Iraa26
23.09.2020 13:40
Const n=9;
var
a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
for i:=1 to n do
begin
a[i]:=random(7)-3;
write(a[i]:4);
end;
writeln;
k:=0;
for i:=1 to n do if a[i]<0 then k:=k+1;
writeln('k = ',k);
end.
Пример:
3 -2 1 1 -2 0 3 0 0
k = 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
menyaylo56
05.10.2020 21:03
Рассмотри расположение внутренних устройств в системном бло- ке компьютера (рис. 4) и определи их названия. Заполни таблицу,используя эти данные....
vldslvkonnov089
05.10.2020 20:56
ХЕЛП ОЧЕНЬ СДАВАТЬ ЧЕРЕЗ 25 МИНУТ Нарисуйте ориентированный граф по весовой матрице. С дерева перебора найдите все возможные пути из вершины А в вершину Е, не проходящие...
EHOT229
30.05.2023 14:13
4. Запишите данный фрагмент программы на языке программирования Python ( ) 1-1 ввод п P-1 Начало цикла для i от до п P=P*1 Конец цикла вывод P= ,P...
vika12325
19.09.2019 03:00
Даны натуральные числа n и k. составить программу вычисления 1^k+2^k+…n^k. через вложеный цикл....
ketti204
19.09.2019 03:00
Спо информатике на написание программы в паскаль: найти сумму ряда 1-2+3-4++56...
frogRICH
12.05.2020 16:39
Что будет напечатано в результате выполнения алгоритма :Алг Пример ;цел X, Y, Z; Начало X:=5;Y=10; Z:=X; X:=Y;Y:=Z;X:=X-10;Y:=Y-5; вывод X, Y, Z; Конец...
Zepstro
12.05.2020 16:39
На валютной бирже за 11 рублей дают 14 долларов, за 22 евро – 21 доллар, за 10 евро – 3 динара, за 5 песо – 2 динара. Сколько рублей можно выменять за 13 песо?...
rodinaolga
12.05.2020 16:37
Запиши последовательность цифр так чтобы в результате получился рисунок...
auntsgarder
12.05.2020 16:36
8 или 9 на выбор. Очень нужна ваша...
Markos14
12.05.2020 16:35
нужна Пропускная некоторого канала связи равна 16000 бит/сек. Сколько времени займет передача файла объемом 32000 байт? ...
Популярные вопросы
Вынесите общий множитель за скобки 4c^6-12c^4...
1
72т050кг-38т216кг выполни действия и сделать проверку...
3
Найдите длины сторон прямоугольника если периметр равен 32 а площадь...
3
Мужской род женский род средний род. множественное число: рисавать...
2
Почему появилась смешанная ? зачем она нужна?...
3
Corynebacterium diphtheriae краткое...
3
Испикла старуха-.покатился он по дороге. встретился _ -он от него...
1
Написать сочинение на казахском языке про правила дорожного движения...
3
Чуваки и уровнение 1479: (7x-5)+29 заранее!...
3
Напишите небольшой рассказ о вашингтоне ( 8-10 предложений) на...
3
var
a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
for i:=1 to n do
begin
a[i]:=random(7)-3;
write(a[i]:4);
end;
writeln;
k:=0;
for i:=1 to n do if a[i]<0 then k:=k+1;
writeln('k = ',k);
end.
Пример:
3 -2 1 1 -2 0 3 0 0
k = 2