Дан массив, содержащий 20 целых чисел из промежутка [-100,100]. напишите программу,позволяющую найти и вывести наименьшее содержщееся в массиве положительное число,десятичная запись которого оканчивается цифрой 7. если таких чисел нет,укажите это

1993nnnn 1993nnnn    3   16.08.2019 08:30    1

Ответы
zka20zka20 zka20zka20  04.10.2020 22:34
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(20,-100,100); a.Println;
  var b:=a.Where(x->(x>0) and (x mod 10=7));
  if b.Count>0 then Writeln('Искомое число ',b.Min)
  else Writeln('Нет подходящих чисел')
end.

Пример
-5 39 27 94 -50 -3 -73 -18 -36 45 -58 47 45 69 -85 -78 -6 -99 4 -32
Искомое число 27
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика