Дан массив случайных чисел а [1..6] из промежутка [-10; 14]. составить программу нахождения суммы положительных элементов массива.

11123323333323232233 11123323333323232233    2   16.05.2019 10:53    2

Ответы
евол евол  10.06.2020 11:24

program raf105;

var  

 a: array[1..6] of integer;

 i,sum: integer;

begin

for i:=1 to 6 do

begin

 a[i]:= random(-10,14);

 if a[i] > 0

   then sum+= a[i];

 writeln(a[i]);

end;

writeln('Сумма положительных элементов: ',sum);

end.

Язык PascalABC
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика