tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив из n элементов .определить
Дан массив из n элементов .определить среднее арифметическое кратных 5 и некратных 10.решите .буду
yiliamasegorova
2 03.06.2019 02:00
21
Ответы
ddddsfvxsf
03.07.2020 15:34
Var
a:array[1..10000]of integer;
n,i,k,c:integer;
summ:real;
begin
readln(n);
for i:=1 to n do
a[i]:=random(100);
for i:=1 to n do begin
if (a[i] mod 5=0)or(a[i] mod 10>0) then begin
c:=c+a[i];
k:=k+1;
end;
end;
summ:=c/k;
writeln(summ);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Dzdze
25.05.2019 00:20
)информационный объем текста, подготовленного с компьютера , равен 3,5 кб. сколько символов содержит этот текст?...
максимус67
25.05.2019 00:20
Определить среди 3 введенных чисел (a,b,c) количество отрицательных и положительных. если больше отрицательных то найти произведение этих 3 чисел, а иначе найти max из трех...
Leramedvedeva12
25.05.2019 00:20
1.запишите натуральный ряд чисел в двоичной системе счисления (до четырех разрядов) 2.переведите числа из одной системы счисления в другую : 10101^2=а^10 10101^8=a^10 10101^16=a^10...
dierchik25
25.05.2019 00:20
Рассмотрите выращиваемый на грядке лук как стистему , взаимодействующую с окружающей средой . опишите входы и выходы этой системы ....
Рыжик151
07.06.2019 20:00
Одате рождения одного китайского поэта известно,что он родился ранее 1100 года,но позднее 1070,а также,что год кратен 7 и 5 одновременно.составьте программу проверяющую,может ли вводимый...
maksfire
04.02.2021 18:35
1) В про¬грам¬ме «:=» обо¬зна¬ча¬ет опе¬ра¬тор присваивания, знаки «+», «-», «*» и «/» — соответственно опе¬ра¬ции сложения, вычитания, умно¬же¬ния и деления. Пра¬ви¬ла вы¬пол¬не¬ния...
ляляляяяяяя
09.12.2020 20:09
В какое программе использовать 3D моделирование О каком году была разработана программа...
Dima0044
09.12.2020 20:09
Задание 1. Распределите инструменты программы Sketch Up по группам в зависимости от НХ Назначения:1-Инструменты рисования, 2-Инструменты модификации; 3-Инструменты редактированияA)...
PandaVo
29.04.2020 20:40
У повітрі залізна деталь розтягнула пружину динамометра з силою 7,7 Н, а у воді — з силою 3,9 Н. Яка виштовхувальна сила діє на деталь у воді?...
dashalimonka2
29.04.2020 20:40
Перше число у 2,5 раза більше другого. Знайдіть ці числа якщо їхня сума дорівнює 35 Буду дуж вдячна...
Популярные вопросы
Что удивляет и поражает в этом приключении(гулливер в стране лилипутов)? объясните....
2
Как произносится: i like it profession journalism. profession journalism interesting...
3
Угол падения на границу двух сред составляет 60,а угол преломления 45,определите...
3
(8/x+x^2)√x найти производные функций...
2
Объясните смысл понятия духовный воин и духовное служение...
2
В1. назовите органы дыхания хордовых. в2. назовите органы выделения черепных. с1....
3
Решите , вычислите б) 5 3\4*12 в) (2,6-1\5): 3\8...
3
Превращение одного элемента в другой происходит при а) только при а распаде б) только...
1
Изначальным исочником энергии в большинстве экосистем служит...
2
Выражение: 6m-3d 5m+3d - 6m+5d 6m+5d...
3
a:array[1..10000]of integer;
n,i,k,c:integer;
summ:real;
begin
readln(n);
for i:=1 to n do
a[i]:=random(100);
for i:=1 to n do begin
if (a[i] mod 5=0)or(a[i] mod 10>0) then begin
c:=c+a[i];
k:=k+1;
end;
end;
summ:=c/k;
writeln(summ);
end.