Дан массив из n чисел. составить программу для вычисления суммы элементов массива, имеющих чётные индексы. паскаль

EvGeniusYT EvGeniusYT    2   07.09.2019 03:00    2

Ответы
alexweber2016 alexweber2016  06.10.2020 22:17
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  Write('Сумма элементов с четными индексами ',
      a.Where((x,i)->i.IsOdd).Sum)
end.

Пример
n= 13
81 6 -34 -33 -13 86 -14 -49 -28 -20 -93 5 -62
Сумма элементов с четными индексами -5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика