tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив из n чисел. найти
Дан массив из n чисел. найти среднее арифметическое элементов, удовлетворяющих условию 2< =[i]< =8. если таких элементов нет, вывести сообщение об этом.
dzamshutor
1 25.05.2019 14:30
2
Ответы
Елена060720007
21.06.2020 18:20
Program zad;
var i,m:longint;
sum,count:real;
A:array [1..n] of longint;
begin
sum:=0; count:=0;
for i:=1 to n do
begin read(m); A[i]:=m end;
for i:=1 to n do
if (A[i]>=2) and (A[i]<=8)
then begin sum:=sum+A[i]; count:=count+1 end;
sum:=sum/count;
if (sum<0)
then writeln('Элементов удовлетворяющих условию нет')
else writeln(sum);
end.
P.S. Переменную n во всем тексте программы следует заменить на конкретное натуральное число!
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kirillm3
11.05.2020 15:59
КТО ДАСТ ОТВЕТ ТОМУ 1. На рисунке представленалгоритм добавления сноски.Внимательно прочитай его изаполни пробелы в алгоритмедобавления сноски. ответызапиши в поле ниже череззапятую:a...
Kharin86
11.05.2020 15:59
Напишите функцию find(корень, значение), которая возвращает указатель на узел, имеющий заданное значение. Если такого значения нет, то функция должна возвращать NULL. #include #include...
0Kirill104810
11.05.2020 16:00
Компьютерная анимацыя это-что?...
timca2014
11.05.2020 16:00
Https://user39597.clients-cdnnow.ru/image/700d03ab4e801952e3027b0dadd4bc04.jpg?w=684&usm=20&auto=format решите На рисунке показаны результаты выполнения команды СМЕСТИТЬСЯ...
alinkalapko049
11.05.2020 16:00
Определите типы алгоритмов:• Сбор рюкзака в поход...
Анастасия73829237
22.04.2020 13:25
10) Web-страница имеет формат (расширение): a) *.txt b) *.htm c) *.doc d) *.rtf e) *.exe 11) Компьютер, подключенный к Internet, обязательно имеет : a) IP адрес b) Web сервер c)...
Dddgirl777
22.04.2020 13:26
Що хорошого у фільмі, а що ні. Чому?Яка відмінність між романом Чорна рада і фільмом знятим по роману?твір Чорна рада...
romaalykulov
22.04.2020 13:26
У исполнителя Альфа две команды, которым присвоены номера: 1. прибавь 5; 2. умножь на b (b — неизвестное натуральное число; b ≥ 2). Выполняя первую из них,...
dima1107
22.04.2020 13:26
10 КЛАСС нужно написать программу Pascal ABC!! Заранее...
FSoxGy
22.04.2020 13:26
Сколько существует натуральных чисел x, для которых выполняется неравенство AB ( 16 СС) x 311 ( 8 CC)? В ответ укажите только количество чисел, сами числа писать не нужно....
Популярные вопросы
Нужна , 20 , по подробнее треугольник авс вписан вокружностьс центром в точке...
3
Петя и оля купили одинаковые тетради по цене 12 руб. заплатил за тетради на 24...
1
Объясните слова а.с.пушкина? который писал что европа была растерзанной и издыхающей...
3
Короткое сочинение на тему о детей в великой отечественной войне ! по литре задали...
1
Морфологический разбор слова...
1
Из данного перечня веществ выберите те , с которыми взаимодействует оксид фосфора(5):...
1
Синтаксический разбор ! полководец суворов говорил: — память есть кладовая ума,...
2
5700x0,105-87x1,7+8009: 1000-8009x0,001 ответ должен быть 450,6...
3
Решить ! станок при изготовлении первой партии деталей затратил времени на 2...
1
Напишите 5-10 вопросов экологическим кризисам в биосфере...
1
var i,m:longint;
sum,count:real;
A:array [1..n] of longint;
begin
sum:=0; count:=0;
for i:=1 to n do
begin read(m); A[i]:=m end;
for i:=1 to n do
if (A[i]>=2) and (A[i]<=8)
then begin sum:=sum+A[i]; count:=count+1 end;
sum:=sum/count;
if (sum<0)
then writeln('Элементов удовлетворяющих условию нет')
else writeln(sum);
end.
P.S. Переменную n во всем тексте программы следует заменить на конкретное натуральное число!