tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив из 7 чисел, которые
Дан массив из 7 чисел, которые вводятся с клавиатуры, вывести на экран значения элементов массива. сосчитать произведение всех ненулевых элементов массива. pascal abc.net
Булат228337
3 28.08.2019 00:50
2
Ответы
vikacatcatcat
05.10.2020 23:43
Полная глупость: вводить с клавиатуры данные и тут же их выводить.
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('П=',ReadArrReal('Введите 7 чисел:',7).Println.Where(x->x<>0).
Aggregate(1.0,(x,y)->x*y))
end.
Пример
Введите 7 чисел: 3.5 -18.3 0 14 174.32 -15 0.17
3.5 -18.3 0 14 174.32 -15 0.17
П=398597.4972
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
2112x2n3t
18.05.2019 01:30
Компьютер отличается от другого технического устройства тем, что он…новый вопрос * 1 обрабатывает информацию 2работает под программы 3 работает под программы и обрабатывает информацию...
seksi2505
18.05.2019 01:30
Май август октябрь декабрь как классифицировать?...
mariadenisovna
18.05.2019 01:30
Кино, пальто, радио,шоссе как классифицировать...
ДарьяКолисан
15.07.2019 10:50
Как представлено число 250 в восьмеричной системе счисления...
samo345
15.08.2019 08:30
среди чисел a,b,c,d найти сумму целых чисел составьте программу по этой на pascal abc...
alexperovo2006p00qrr
26.05.2020 21:35
распечатать по распечатать по...
MariaMmchka
26.05.2020 21:35
Дан целочисленный массив из 30 элементов. Элементы массива могут принимать значения от –1000 до 1000. Напишите программу, которая находит и выводит среднее арифметическое всех...
SoktoevTimur
27.05.2020 22:07
Тема:Программирование повторения графических объектов Напишите программу, которая, с цикла, выводила бы на экран следующий рисунок(скрин). Пример задачи: SCREEN 9 INPUT “количество...
eerihovp08oqz
27.05.2020 09:31
1.На какие группы можно разделить графические редакторы?2. Что лежит в основе растровой графики? Векторной?3. Что вы знаете о пикселях?4. Что такое цветовая модель?5. Почему...
ASLiza1992
29.10.2020 13:26
Выберите верное утверждение. Какие обьекты связывает отношение “являються разновидностью“?...
Популярные вопросы
Найдите координаты вершины параболы (y=x-2)^2-4.Посторойте эту параболу...
3
Во Что является главной причиной возникновения магнитного поля Земли? (Выбрать...
2
Уважаемые философы, обращаюсь к вам. Если ответ подойдёт, ...
3
Задания А,Б,В Буду очень благодарен за ответ!...
3
Какую политику проводил Тауекель хан для объединению казахских земель...
2
Сравните засуху или отсутствие пищи и радиацию как факторыокружающей среды,...
3
Почему перед началом закаливания рекомендуется вылечить больные зубы...
3
выберите ответ и минимум или максимум...
3
Проаналізуйте Корюківську трагедію. Зробіть власні припущення: чому партизани...
3
Що уособлює образ галерника в однойменному Biрші Л. де Гонгори?...
1
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('П=',ReadArrReal('Введите 7 чисел:',7).Println.Where(x->x<>0).
Aggregate(1.0,(x,y)->x*y))
end.
Пример
Введите 7 чисел: 3.5 -18.3 0 14 174.32 -15 0.17
3.5 -18.3 0 14 174.32 -15 0.17
П=398597.4972