tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив из 20 натуральных
Дан массив из 20 натуральных чисел. составить программу суммы элементов, кратных данному числу d .
саша8038
3 30.07.2019 07:30
2
Ответы
nazhigp08m0u
27.09.2020 20:21
Const
n=20;
var a:array[1..n] of integer;
var i,d,s:integer;
begin
s:=0;
writeln('Введите число d');
readln(d);
writeln('Введите массив');
for i:=1 to n do begin
read(a[i]);
if a[i] mod d = 0 then s:=s+a[i];
end;
writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Лесолес
23.12.2020 18:41
Если в текстовом процессоре создать таблицу, затем эту таблицу выделить полностью и нажать кнопку на панели форматирования, что получится в результате? 1 И таблица раздвинется...
Ламинарка
23.12.2020 18:42
Рін сипаттаңдар ҚоспалардыңтүрлеріәркелкіТұндыруН.ант жәнеТұнбаныерітіндіденӨзара бірбірінде ерімуз өндіруСүзуейтін заттараркылыКо...
molotower
23.12.2020 18:42
информатика 8 класс,задание в фото.таблица истинности не видна до конца(...
SimbatDuysebek
23.12.2020 18:42
1. Компьютерлік графика нешеге бөлінеді? A. 5B. 2C. 32. графикалық редакторы суреттер салуға, өңдеуге,сақтауға, қағаз басып шығаруға, растрлық бейнелермен жұмыс істеуге арналган...
kurstak77
27.11.2020 09:26
Чертёжнику был дан исполнения следующий алгоритм повторит 2 раза сместиться на (-3 , -4) сместиться на (3, 3) сместиться на (1, -2) конец какую единственную команду надо...
svetokot2005
27.11.2020 09:26
Вычислить значение функции у(х) и вывести его на экран 2x - 5+x , если х 10Y= 5x2-x, если 10 =x 137x-5, если x. =13...
16653
27.11.2020 09:26
Шестнадцатеричный код некоторого растрового изображения 1A2642FF425A5A7E16. Подсчитайте информационный объём картинки – количество битов и байтов, которые она занимает в...
Julli0Kub
27.11.2020 09:34
Какие предложения являются высказываниями? Все треугольники равнобедренные. (13-2*4)*4=-7 Число 123 меньше числа -124 Сумма чисел 4 и х равна 15 посуду....
ArtemPlayGames
27.11.2020 09:34
сделать одну задачу по информатике...
Оливия131
27.11.2020 09:35
Написать программу закрашенного куба в QBasic...
Популярные вопросы
5класс. тема десятичные дроби номер начертите отрезки ав=1,3 см; сд=2,1см;...
2
Что обозначает умирающий лик в стихотворение камышы...
2
Коршаган ортаны коргау такырыбына багдарлама жасандар переведите...
3
Які є різновиди календарно-обрядових пісень...
3
Сторона равностороннего треугольника abc равна 12см .прямые ma,mb,mc образуют...
2
Выделите целую часть из дробй 17/4, 53/12, 7023/1000...
3
Чему равна разность фаз колебаний двух точек, отстоящих друг от друга...
2
Орфограммы в словах : сосна, стоит, тенистый, силач, закричал, шаги, указочка...
3
Напишите небольшое сообщение на тему народы латинской америки умоляю...
3
Составить 1 предложение с придаточным условным,4 составить 5 в голову...
3
n=20;
var a:array[1..n] of integer;
var i,d,s:integer;
begin
s:=0;
writeln('Введите число d');
readln(d);
writeln('Введите массив');
for i:=1 to n do begin
read(a[i]);
if a[i] mod d = 0 then s:=s+a[i];
end;
writeln(s);
end.