Дан массив из 13 элементов. элементами массива являются первые 13 нечетных чисел. найти произведение элементов этого массива. написать программу в паскале, как можно проще, без лишних наворотов, .

JaspeR9 JaspeR9    1   06.09.2019 18:00    2

Ответы
sveta484 sveta484  06.10.2020 21:35
Var   proizv:int64; 
  a: array [1..13] of integer;
begin
  // заполняем массив
  for var i:=1 to 13 do
    a[i]:=i+i-1;
  proizv:=1;
  // основной цикл
  for var i:=1 to 13 do
    proizv:=proizv*a[i];
  writeln('Произведение = ',proizv);
end.

Это работает в АБС-паскале
Типа данных integer мало для хранения произведения, но int64 - достаточно
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика