Дан массив из 12 целых чисел проверить является ли он по возрастанию. написать программу на с++​

7575757575 7575757575    2   10.11.2019 07:52    4

Ответы
top76543211vfjo top76543211vfjo  10.10.2020 12:06

Исходник ниже. В задаче говорится, что чисел ровно 12, поэтому сделал статический массив на константное количество элементов. Если предполагается, что программа должна работать и на других размерах массива, то можно сделать динамический массив или использовать контейнер vector.

Объяснение:

#include <iostream>

int main(){

   const int n = 12;

   int a[n];

   for(int i = 0; i < n; i++){

       std::cin >> a[i];

   }

   bool ascending= true;

   for(int i = 1; i < n; i++){

       if (a[i-1] > a[i]){

           ascending = false;

           break;

       }

   }

   if (ascending){

       std::cout << "Yes" << std::endl;

   }

   else{

       std::cout << "No" << std::endl;

   }

   return 0;

}    

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика