Дан массив из 100 целых чисел. Написать программу нахождения суммы нечетных элементов массива. C++

GagarinPSK GagarinPSK    1   28.11.2020 15:54    0

Ответы
nika0483 nika0483  28.12.2020 15:56

#include <iostream>

#include <time.h>

using namespace std;

int main()

{

srand(time(NULL));

int N[100];

int sum = 0;

for(int i=0;i<100;i++){

 N[i] =rand();

}

cout << "vse elementu" << endl;

for(int i=0;i<100;i++)

 cout << N[i] << " ";

cout << endl;

cout << "nechetnue elementu" << endl;

for(int i=0;i<100;i++){

 if(N[i]%2!=0)

  sum = sum + N[i];

  cout << N[i] << " ";

}

cout << endl;

cout<< "suma nechetnuh =  " << sum << endl;

system("pause");

return 0;

}

Объяснение:

Написал программу так, что-бы сначала выводило 100 элементов(рандом чисел), потом выводило нечетные элементы, потом выведет уже суму нечетных

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика