Дан массив из 10 элементов. составить программу которая даёт ответ на вопрос есть ли в массиве более одного элемента равного максимальному. ответ выводится в виде да/нет. pascal.

lazyseal1488 lazyseal1488    1   12.09.2019 21:30    5

Ответы
sofiya84 sofiya84  07.10.2020 10:28
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,1,9); a.Println;
  if a.Where(t->t=a.Max).Count>1 then
    Writeln('Есть элементы, равные максимальному')
  else
    Writeln('Нет элементов, равных максимальному')
end.

Примеры
5 5 6 4 4 1 6 9 8 3
Нет элементов, равных максимальному

1 8 1 5 2 3 1 4 5 8
Есть элементы, равные максимальному
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика