:дан массив из 10 целых чисел,от -20 до 20 . напишите программу,заменяющую первый отрицательный элемент массива нулем. решить!

nast60 nast60    1   01.07.2019 05:20    3

Ответы
fjfnk fjfnk  02.10.2020 17:05
var a:array [1..10] of integer;
     i,n,b:integer;
Begin
  for i:=1 to 10 do
    read(a[i]);
  for i:=1 to 10 do
  begin
    if b=0 then if a[i]<0 then 
       begin
         a[i]:=0;
         b:=1;
       end;
  end;

  for i:=1 to 10 do
  write(a[i],' ');
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы