Дан массив из 10 целых чисел. Напишите программу вычисления суммы элементов массива среди, трехзначных чисел, у которых последняя цифра четная, первая нечетная. Нужна программа

driftstiwrx driftstiwrx    2   26.01.2021 05:40    8

Ответы
Вано153 Вано153  25.02.2021 05:40

program z1;

var a:array[1..10] of integer;

i,s:integer;

begin

s:=0;

write('Массив: ');

for i:= 1 to 10 do

begin  

a[i]:=random(1000);  

write(a[i],'  ');

if (a[i]>99) and (a[i]<1000) and (a[i] mod 10 mod 2 = 0) and (a[i] div 100 mod 2 <> 0) then s:=s+a[i]

end;

writeln;

write('Сумма элементов массива среди, трехзначных чисел, у которых последняя цифра четная, первая нечетная: ',s)

end.

Объяснение:

(a[i]>99) and (a[i]<1000) - проверка числа на трёхзначность

(a[i] mod 10 mod 2 = 0) - проверка последней цифры числа на чётность

(a[i] div 100 mod 2 <> 0) - проверка первой цифры числа на нечётность

все условия соединены and, т.к. должны выполняться одновременно

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика