Дан массив d(n). найти минимальный среди элементов, больших суммы,и найти количество элементов, не равных максимальному. написать программу в паскале,)

arshon1 arshon1    3   16.05.2019 18:18    5

Ответы
mixakov05 mixakov05  10.06.2020 13:03

program raf105;

const

 n = 10;

var

 d:array[1..n] of integer;

 min,max,sum,notmax,i: integer;

begin

max:= -10000;

min:= 10000;

writeln('Заполните массив');

for i:=1 to n do

begin

 readln(d[i]);

 sum+= d[i];

 if max<d[i]

   then max:= d[i];

end;

for i:=1 to n do

begin

 if d[i]<>max

   then notmax+= 1;

 if (d[i]>sum) and (d[i]<min)

   then min:= d[i];

end;

if min<>10000

 then writeln('Минимальный среди элементов, больших суммы: ',min)

 else writeln('Минимальный среди элементов, больших суммы: Не найдено');

writeln('Количество элементов, не равных максимальному: ',notmax);

end.

Язык PascalABC
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика