tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан массив целых чисел
Дан массив целых чисел , определить в нем количество положительных и отрицательных
vfeukb59Pavek
2 21.08.2019 17:30
3
Ответы
skvorcova19991993
05.10.2020 09:44
//PascalABC.NET 3.2 сборка 1318
Const n=4;
begin
var ar:=readarrInteger(n);
writeln('Positive:',ar.Where(x -> x>0).Count);
writeln('Negative:',ar.Where(x -> x<0).Count);
end.
Пример ввода:
1
2
0
-1
Пример вывода:
Positive:2
Negative:1
ПОКАЗАТЬ ОТВЕТЫ
AnnyMay2629
05.10.2020 09:44
// C++
#include <iostream>using namespace std;const int N = 200;
int main() { setlocale(LC_ALL, "rus"); int data[N]; int Pol, Otr, sizemas; Pol = 0; Otr = 0; cout << "Введите размер массива" << endl; cin >> sizemas; cout << "Введите элементы массива (без 0)" << endl; for(int i=0; i<sizemas; i++) { cin >> data[i]; } for(int i=0; i<sizemas; i++) { if(data[i] >= 0) { Pol++; } else { Otr++; } } cout << "Положительных элементов: " << Pol << endl << "Отрицательных элементов: " << Otr << endl; return 0;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
hhhh34
22.08.2019 18:10
Как называется бренд кторый написан на букве w вот такие буквы в,е,к,т,о,т,а,н,к...
anastysiaparsh
22.08.2019 18:10
10) передача данных через adsl-соединение заняла 2 минуты. за это время был передан файл, размер которого 3 750 кбайт. определите минимальную скорость (бит/c), при...
мари420
22.08.2019 18:10
55 . какое значение получит переменная y после выполнения алгоритма? х: =1 у: =2*х у: =у+3 у: =у*х у: =у+4 у: =у*х у: =у+5 запишите логическое выражение,истинное при...
surmistovak
04.11.2020 09:22
1. Основное устройство вывода информации, предназначенное для отображения текста или графической информации3. Средство для перевода графической и текстовой информации...
оксана754
18.04.2021 16:40
лучший ответ и ставлю 5 звёзд Информатика 7 класс решить задания 4 и , ограниченное время >...
Vanomasssss
11.06.2019 04:52
Подскадите, , точный алгоритм сокращения дробей...
aleksapopov1
11.06.2019 04:52
На хранение целого числа отвели 12 бит. сколько чисел можно закодировать таким образом?...
vladgrigav
20.05.2019 02:50
1. какие устройства могут подключиться к интернету ? ? 2.какие подключения к сети интернета наиболее распространены? 3. для чего используется модем? 4.при каких подключения...
unucozi
02.06.2020 18:54
Файл с именем «рисунок.bmp» находится в папке «Группа», которая вложена в папку «Мои рисунки» на диске С. Укажите расширение файла: а) С:\Мои рисунки\Группа\рисунок.bmp...
MarinaKim111
01.06.2020 18:58
Какой вход AUX на старых касетных магнитофонах...
Популярные вопросы
написать письмо по английскому за планом (4, 10, 11, 12, 13, 14...
2
Найди соответствие между костями и отделами скелета, записав рядом...
2
Б1=2, q=-2 найти первые 4 члена прогрессии...
2
О чём заставляет задуматься Раскольникова вид «великолепной панорамы»...
2
Раскрой скобки и у выражение: 24−(17+x). ответ (записывать без...
3
Вставь глагол play, do или go английский a) Football b) archery...
3
Порівняйте московське середновіччя...
3
Нужно доказать, что треугольник FDE равнобедреннный. Подробно и...
1
На каком рисунке изображено множество решений неравенства?В ответ...
3
Подумайте и постарайтесь выяснить следующие особенности для Северного...
2
Const n=4;
begin
var ar:=readarrInteger(n);
writeln('Positive:',ar.Where(x -> x>0).Count);
writeln('Negative:',ar.Where(x -> x<0).Count);
end.
Пример ввода:
1
2
0
-1
Пример вывода:
Positive:2
Negative:1
#include <iostream>using namespace std;const int N = 200;
int main() { setlocale(LC_ALL, "rus"); int data[N]; int Pol, Otr, sizemas; Pol = 0; Otr = 0; cout << "Введите размер массива" << endl; cin >> sizemas; cout << "Введите элементы массива (без 0)" << endl; for(int i=0; i<sizemas; i++) { cin >> data[i]; } for(int i=0; i<sizemas; i++) { if(data[i] >= 0) { Pol++; } else { Otr++; } } cout << "Положительных элементов: " << Pol << endl << "Отрицательных элементов: " << Otr << endl; return 0;}