Дан массив a, состоящий из n целых неотрицательных чисел. Ваша задача — выписать элеметы массива a с чётными номерами в начало массива b, а затем дополнить массив b нулями до размера n. Элементы массивов нумеруются с единицы.

Формат входных данных
В первой строке входных данных находится натуральное число n (1≤n≤500) — количество элементов массива.
Во второй строке лежат n целых неотрицательных чисел, разделённых пробелами — элементы этого массива. Элементы массива не превосходят 1000.

Формат выходных данных
Выведите на экран n целых неотрицательных чисел, разделённых пробелами — элементы массива b.

входные данные
4
1 3 3 7

5
4 20 412 3 2
выходные данные
3 7 0 0

20 3 0 0 0

8908903 8908903    3   24.03.2021 12:59    6

Ответы
vugarjalilovp0ci9p vugarjalilovp0ci9p  23.04.2021 13:00

Объяснение:

#include <iostream>

#include <vector>

using namespace std;

int main()

{

int N,counter=0;

cin >> N;

vector<int> a(N, 0);

for (int i = 0; i < N; i++) {

 int b;

 cin >> b;

 if (i % 2 != 0)

  a[counter++] = b;

}

for (int i = 0; i < N; i++)

 cout << a[i]<<" ";

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика