Дан массив a из n натуральных чисел. Требуется вывести все элементы массива, являющиеся двузначными числами.

Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.
На следующей строке через пробел записаны натуральные числа ai (ai≤103) — элементы массива.

Формат выходных данных
Требуется в одной строке через пробел вывести все числа, являющиеся двузначными, в том же порядке, в каком они расположены во входном файле.

входные данные
4
100 20 4 318

10
42 7 59 7 212 47 777 66 89 6
выходные данные
20

42 59 47 66 89

Salkin355 Salkin355    3   12.02.2021 22:18    4

Ответы
matvejp816 matvejp816  14.03.2021 22:20

#include <iostream>

#include <cmath>

using namespace std;

signed main(){

   int n,x;

   cin >> n;

   while(n--){

       cin >> x;

       int X = x, cnt = 0;

       while(X > 0){

           X /= 10;

           cnt++;

       }

       if(cnt == 2)

           cout << x << " ";

   }

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика