Дан массив a из n целых чисел. Требуется вывести второй, четвертый и т.д., т.е. элементы, стоящие под четными номерами.

Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.
На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных
Требуется в одной строке через пробел вывести все числа, стоящие на четных местах.

входные данные
4
100 20 4 318

10
42 7 59 7 212 47 777 66 89 6
выходные данные
20 318

7 7 47 66 6

ОСА717 ОСА717    2   12.02.2021 22:29    12

Ответы
goodman91 goodman91  12.02.2021 22:30

\sqrt{152}

Объяснение:

\sqrt{7458}

ПОКАЗАТЬ ОТВЕТЫ
Санжик707 Санжик707  12.02.2021 22:30

#include <iostream>

#include <cmath>

using namespace std;

signed main(){

   int n;

   cin >> n;

   int arr[n];

   for(int i = 0; i < n; i++)

       cin >> arr[i];

   for(int i = 1; i < n; i+= 2)

       cout << arr[i] << " ";

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика