Дан массив a из n целых чисел. Требуется вывести только элементы с четными значениями.

Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.
На следующей строке через пробел записаны целые числа ai (∣∣ai∣∣≤103) — элементы массива.

Формат выходных данных
Требуется в одной строке через пробел вывести все четные числа, в том же порядке, в каком они расположены во входном файле.
входные данные
4
100 -20 4 318

10
-42 70 59 76 21 47 77 66 89 60
выходные данные
100 -20 4 318

-42 70 76 66 60

Топирчик Топирчик    1   12.02.2021 21:58    3

Ответы
kkostova kkostova  14.03.2021 21:59

#include <iostream>

using namespace std;

signed main(){

   int n, x;

   cin >> n;

   while(n--){

       cin >> x;

       if(x % 2 == 0)

           cout << x << " ";

   }

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика