Дан массив a из n целых чисел — информация о количестве осадков, выпавших за каждый из n дней. Требуется определить, в какие дни осадков не было.

Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.
На следующей строке через пробел записаны целые числа ai (0≤ai≤103) — количество осадков в i-й день.

Формат выходных данных
Требуется в одной строке через пробел вывести номера дней, в которые осадков не было.

входные данные
4
100 20 0 318

10
0 0 0 0 0 47 777 66 89 6
выходные данные
3

1 2 3 4 5

super123jack super123jack    3   16.02.2021 00:41    40

Ответы
Кристинанана Кристинанана  18.03.2021 00:44

#include <sstream>

#include <iostream>

int main()

{

size_t n;

std::cin >> n;

std::ostringstream out;

for (size_t i = 0; i < n; ++i)

{

static short a;

std::cin >> a;

if (a <= 0) out << (i + 1) << ' ';

}

std::cout<<out.str();

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика