Дан массив 20 целых, диапазон от -15 до +20 найти мин элемент и сумму кратных 3( написать программу pascal )

ilham11997766 ilham11997766    1   12.09.2019 13:50    3

Ответы
alina130410 alina130410  07.10.2020 09:48
Program n1;
const n=20;
var a: array [1..n] of integer;
i,min,sum:integer;
begin
randomize;
sum:=0;
write('исходный массив:');
for i:=1 to n do
begin
a[i]:=random(36)-15;
write(a[i],' ');
if a[i] mod 3=0 then sum:=sum+a[i];
end;
writeln;
min:=a[1];
for i:=1 to n do if min>a[i] then min:=a[i];
writeln('минимальный элемент:', min);
writeln('сумма кратных трем: ',sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика