Дан двумерный массив размером mxn массив заполнен случайными числами от 5 до 10. найти произведение значений по главной диагонали и сумму по побочной диагонали.нужно написать программу в паскале к этому. !

Vikak005love Vikak005love    2   20.04.2019 07:36    2

Ответы
dedrina dedrina  08.06.2020 02:02

var

A : array [1..999, 1..999] of Integer;

p, s, i, j, m, n: Integer;

begin

// Инициализация переменных для суммы и произведения

s:= 0;

p:= 1;

Write('Введите количество строк - ');

ReadLn(m);

Write('Введите количество столбцов - ');

ReadLn(n);

// Заполнение

for i:=1 to m do

for j:=1 to n do

A[i,j]:=Random(6)+5;

// Вывод массива

for i:=1 to m do

begin

for j:=1 to n do

Write(A[i,j]:3);

WriteLn();

end;

// Подсчёт произведения и суммы

for i:= 1 to m do

begin

j:= i;

s+= A[m-i+1,j];

p*= A[i,j];

end;

WriteLn('Произведение = ', p);

WriteLn('Сумма = ', s);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика