Дан двумерный массив. определить, есть ли среди элементов массива данное число q. написать программу, . заранее : )

Лиро1 Лиро1    3   19.09.2019 13:10    3

Ответы
MAN1337228 MAN1337228  08.10.2020 02:19
// PascalABC.NET 3.3
const n=7;
begin
  Writeln('Исходный массив:');
  var a:=MatrRandom(n,n,-10,10); a.Println(6);
  var q:=ReadInteger('q = ');
  var m:=a.ElementsByRow.Where(x->x=q).Count;
  if m>0 then writeln('YES') else writeln('NO');
end.

Пример:
Исходный массив:
     0    -1   -10     7     5     5     5
    -3     8     8    -8     4    10     0
    -2     9    -1    -4   -10    -2     2
    -9     6    10    -4     3    -5     4
    -3     9     4    -6     8    10    -2
     4    -1    -2     8     9    -8    -3
     5     6     2     5     9     3     8
q =  9
YES
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика