Дан двухмерный массив m*n случайных целых чисел, которые должны генерироваться в диапазоне [-5, 7], где 1 ≤ т ≤ 9, 1 ≤ n ≤ 10. составить программу: a) вывода на экран элементов исходного массива; b) вывода на экран элемента, расположенного в правом верхнем углу массива; c) вывода на экран элемента, расположенного в левом нижнем углу массива; d) вывода на экран любого элемента второй строки массива; e) вывода на экран любого элемента третьего столбца массива; f) вывода на экран любого элемента массива.

wikkouiii wikkouiii    3   11.09.2019 02:20    5

Ответы
Niks78492986 Niks78492986  07.10.2020 06:33
Const m=9; n=10;
var 
a:array[1..m,1..n] of integer;
i,j,m1,n1:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to m do
 begin
 for j:=1 to n do
  begin
   a[i,j]:=random(13)-5;
   write(a[i,j]:4);
  end;
  writeln;
 end;
writeln('Элемент, расположенный в правом верхнем углу массива: ',a[1,n]);
writeln('Элемент, расположенный в левом нижнем углу массива: ',a[m,1]);
writeln('Какой элемент второй строки нужно вывести?');
readln(n1);
writeln('Элемент, расположенный во второй строке в ',n1,' столбце: ',a[2,n1]);
writeln('Какой элемент третьего столбца нужно вывести?');
readln(m1);
writeln('Элемент, расположенный в третьем столбце в(о) ',m1,' строке: ',a[m1,3]);
writeln('Какой элемент массива нужно вывести?');
readln(m1,n1);
writeln('Элемент, расположенный в(о) ',m1,' строке в(о) ',n1,' столбце: ',a[m1,n1]);
end.

Пример:
Исходный массив:
   7  -5   7   7   3   3   4   6  -5   1
   7  -3  -1  -5  -1  -1   2   4  -2   6
   0   3   4  -2  -3  -1  -2   7   3  -2
   7   3  -2   6  -2   4  -1   1   0   3
   2   4  -1   6  -2   2   5   4   4  -1
  -1  -4   5   2   5  -1  -5   5  -5   0
   4   2  -4   2  -3   1  -1   5   3   4
  -2   5  -4  -1   5   5   3   3  -2   1
   5   2  -3   3   5   4   3   3   4   5
Элемент, расположенный в правом верхнем углу массива: 1
Элемент, расположенный в левом нижнем углу массива: 5
Какой элемент второй строки нужно вывести?
Элемент, расположенный во второй строке в 4 столбце: -5
Какой элемент третьего столбца нужно вывести?
Элемент, расположенный в третьем столбце в(о) 5 строке: -1
Какой элемент массива нужно вывести?
Элемент, расположенный в(о) 6 строке в(о) 2 столбце: -4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика