Дан целочисленный одномерный массив. составьте программу, которая искала бы наибольший положительный элемент.

zhenyaermakov zhenyaermakov    3   14.06.2019 18:00    0

Ответы
debchai123 debchai123  02.10.2020 01:57
Program primer;
const n=100;
var a:array[1..n] of integer;
i,max:integer;
begin
writeln('vvedite massiv');
for i:=1 to n do
readln(' ', a[i]);
max:=a[1];
for i :=1 to n do
if (a[i]>a[1]) and (a[i]>0) then max:=a[i];
writeln('max=',max);
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика