Дан целочисленный массив из 30-ти элементов.написать программу,которая позволит найти среднее арифметическое положительных элементов массива .

sbordog1337bogdan sbordog1337bogdan    3   29.05.2019 02:40    3

Ответы
131756 131756  27.06.2020 01:33
Паскаль:

var mas : array[1..30] of longint;
n,i : longint;
r : real;
begin
 for i:=1 to 30 do read (mas[i]);
 n:=30; r:=0;
 for i:=1 to 30 do begin
  if mas[i]<1 then begin mas[i]:=0; n:=n-1;
  r:=r+mas[i];
 end;
 writeln(r/n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика