tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Дан целочисленный массив
Дан целочисленный массив из 30 элементов. найти, сколько в нём пар одинаковых соседних элементов. на с++,
fragerin
1 05.07.2019 09:50
2
Ответы
тузель
28.07.2020 21:29
#include <iostream>
using namespace std;
#define N 30
int main(int argc, char* argv[])
{
setlocale(LC_ALL, "Russian");
int a[N];
int k = 0;
for(int i=0;i<N;i++)
{
cout<<"a["<<i+1<<"]=";
cin>>a[i];
}
for(int i=1;i<N;i++)
if(a[i]==a[i-1])
k++;
cout<<k<<"пар"<<endl;
system("pause");
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Natashkasunny05
24.09.2019 20:10
Информационное сообщение на языке, первоначально записанное в 8-битном коде кои-8, было перекодировано в 16 битовую кодировку unicod. в результате информационный объем сообщения...
ЧеТКиЙВсЕУмиЙ
24.09.2019 20:10
По древней легенде мудрец, придумавший шахматы потребовал у персидского шаха такое вознаграждение: пусть на шахматную доску кладут зёрна: на 1-ую 1 зерно, на 2-ую - 2 зерна, на...
yamoskit00
23.12.2020 19:02
Заполните массив из 10 элементов степенями числа 2 (от 21 до 2N), так чтобы элемент с индексом i был равен 2i. На Питон...
blaccyee0666
23.12.2020 19:02
Як варто виступати перед глядачами із презентацією?...
пожалуйста189
23.12.2020 19:00
Для решения каких задач предназначены функции категории Ссылки и массивы? 2. Приведите примеры использования функции ВПР()? 3. Какие значения вводятся в поле Интервальный просмотр?...
катя4003
12.01.2021 09:35
Составить блок схему по формуле...
liliaadderson
12.01.2021 09:35
Объясните разницу между низкоуровневыми и высокоуровневыми языками программирования ?...
minakim28mina
11.05.2021 18:00
Выберите условные операторы if xay then x=0 else y=0;if x sy then x=0;y=0 else write(y);if a=b then begin; c=3 end else c=1;if c 2 or a 2 then read(a) else read(0);...
Оаоагигвшпоа
11.05.2021 18:00
можете ли вы с этим заданием, (написать легчайший и понятный код для начинающих) Используя подпрограммы (функций) в С++, найдите что будет больше, сумма положительных или отрицательных...
4535константин20051
11.05.2021 18:00
паскаль ))составить программу, которая по дню выводит время приёма врача Дни недели Часы приёма Понедельник, вторник 8.30-14.30 Среда, четверг 13.00-19.00 Пятница 11.30-17.30...
Популярные вопросы
маххабат дастаны жырдағы жағымды және жағымсыз кейіпкерлерді белгіле. жақсы...
1
по истории Греко персидские 1. Дата войны,2. Причины войны 3. Основные сражения...
1
(15 marks) 4 Choose the correct item. (15 marks)I love going 0)camping in thesummer....
2
Особенности (особенности) бобовых культур * А) с двойной ячейкой, тонкая шторка...
2
Самостоятельная Алкены 1 вариант...
1
Недоросль что из одежды сшил Тришка митрофану...
1
Проспягайте словосочетание «Отырарға барамын» 1 жақ Мен Отырарға бара+мын Біз...
1
ЖАЗЫЛЫМ 12-тапсырма.Дереккөздерденжолға,жолережелерінеқа-тыстықұрамындасынесімдербаржұмбақтарды,мақал-мәтелдердітауыпжаз.Ойдыбілдірудесынесімдердіңатқарыптұрғанқызметінөзсөзіңментаратып...
3
Структурная формула 4,5 диметилгептан...
2
Есть ли в мире такие страны, которые по распространенным в них языкам и религиям...
3
using namespace std;
#define N 30
int main(int argc, char* argv[])
{
setlocale(LC_ALL, "Russian");
int a[N];
int k = 0;
for(int i=0;i<N;i++)
{
cout<<"a["<<i+1<<"]=";
cin>>a[i];
}
for(int i=1;i<N;i++)
if(a[i]==a[i-1])
k++;
cout<<k<<"пар"<<endl;
system("pause");
}