Дан целочисленный массив из 10 элементов. напишите программу, которая находит количество пар элементов массива, в которых хотя бы одно число делится на 3, под парой подразумевается два идущих подряд массива. например : 6; 2 ; 9; -3; 6. ответ : 4. работа в паскаль,

247074 247074    1   06.09.2019 08:00    2

Ответы
крыска235 крыска235  01.09.2020 09:17
Извиняюcь за то что долго
program z1;
var a:array[10];
k,i:integer;
begin
k:=0;
readln(a);
for i:= 1 to 9 do
if (a[i] mod 3 =0) or (a[i+1] mod 3 = 0) then k:=k+1;
end;
writeln(k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика