Дан целочисленный массив из 10 элементов.элементы массива могут принимать целые значения от -50 до 50.составить программу ,позволяющую найти и вывести сумму элементов массива которые кратны 7 и оканчиваются на 5 .гарантируется,что в исходном массиве есть хотя бы один такой элемент. на языке

evkapop evkapop    1   03.06.2019 11:40    3

Ответы
dreakalex dreakalex  01.10.2020 18:21
Const N=10;
TYPE Chisla = array [1..N] of integer;
var f: Chisla;
procedure IChisla (N: integer; var a: Chisla);
begin  for var i := 1 to N do a[i] := random(-50, 50);
end;
procedure OChisla(N: integer;a: Chisla);
begin 
 for var i := 1 to N do write(a[i]:5);
end;
function Sum (a:Chisla): integer;
begin
for var i:=1 to N do  
  if (a[i] mod 7 = 0) and (a[i] mod 10 = 5) then result:= result+f[i]; 
 end;
BeginI
Chisla (N, f);
OChisla (N, f);
writeln ('Вывести сумму', Sum(f));
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика