Да ну трёх значные числа. напишите программу, который определяет: а) есть ли среди цифр заданного целого трёх значного числа одинаковый 123 нет 121 да 222 да б) является ли число перевертышем то есть число десятичной записи которые читаются одинаково слева направо и справа налево 122 нет 121 перевертыш 222 перевертыш

Ханоглан122 Ханоглан122    3   22.09.2019 10:20    4

Ответы
shitovilya shitovilya  08.10.2020 09:17
1.
var a,c:integer; m:set of 0..9; b:boolean;
begin
readln(a);
m:=[];
b:=false;
while a>0 do
 begin
 c:=a mod 10;
 if c in m then b:=true;
 m:=m+[c];
 a:=a div 10;
 end;
if b then writeln('Да')
else writeln('Нет');
end.

Пример:
121
Да

2.
var a,b,c:integer;
begin
readln(a);
c:=a;
b:=0;
while c>0 do
 begin
 b:=b*10+c mod 10;
 c:=c div 10;
 end;
if a=b then writeln('перевертыш')
else writeln('Нет');
end.

Пример:
121
перевертыш
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика