CРОЧНО!НЕОБХОДИМО РЕШИТЬ ЗАДАЧУ НА PYTHON! В некотором вузе абитуриенты проходят предварительное тестирование, по результатам которого могут быть допущены к сдаче вступительных экзаменов в первом потоке. Тестирование проводится по двум предметам, по каждому предмету абитуриент может набрать от 0 до
При этом к сдаче экзаменов в первом потоке допускаются абитуриенты, набравшие по результатам
тестирования не менее по каждому из двух предметов. На вход программы подаются
сведения о результатах предварительного тестирования. Известно, что общее количество участников тестирования не превосходит 500.
В первой строке вводится количество абитуриентов, принимавших участие в тестировании, N
(при этом N ≤ 6). Далее следуют N строк, имеющих следующий формат:

Здесь – строка, состоящая не более чем из 20 символов; – строка, состоящая не более чем из 15 символов; – строка, содержащая два целых числа, разделенных
пробелом, соответствующих , полученным на тестировании по каждому из двух предметов.
При этом и , и разделены одним пробелом. Примеры входных
строк:
Ветров Роман 68 59
Анисимова Екатерина 64 88
Напишите программу, которая будет выводить на экран фамилии и имена абитуриентов, потерпевших неудачу, то есть не допущенных к сдаче экзаменов в первом потоке. При этом фамилии
должны выводиться в алфавитном порядке.

ValeraSmirnov213123 ValeraSmirnov213123    3   07.02.2021 05:36    14

Ответы
colins1987 colins1987  09.03.2021 05:52

#include <iostream>

#include <string>

using namespace std;

int main(){

int i, j, N, mark1, mark2, mark3, count=-1;

string Result[500];

string name, surname, temp;

cin>>N;

for(i=0; i<N; i++){

 cin>>name>>surname>>mark1>>mark2>>mark3;

 if(mark1>=30 && mark2>=30 && mark3>=30 && mark1+mark2+mark3>=140){

  count++;

  Result[count]= name + " " + surname;

 }

}

for(i=0; i<=count-1; i++){

 for(j=i+1; j<=count; j++)

  if(Result[i]>Result[j]){

   temp=Result[i];

   Result[i]=Result[j];

   Result[j]=temp;

  }

}

for(i=0;i<=count;i++)

 cout<<Result[i]<<endl;

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика