CРОЧНО НА С++ На вход программе подаются два целых числа m и n, по модулю не превосходящие 10^6. Если m≥n, то требуется вывести 1, в противном случае — любое другое число.

Условный оператор, операторы сравнения, циклы и функции min, max, abs использовать нельзя!

fayafaya1 fayafaya1    3   12.04.2021 09:36    14

Ответы
yli4ka2007 yli4ka2007  12.05.2021 09:38

#include <iostream>

int main()

{

   int m, n;

   std::cin>>m>>n;

   int target = m - n;  

   std::cout << -1 * (target >> (8 * sizeof(target) - 1))+1;  

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика